Archive for July, 2012

1994 Chevrolet hesitation problem

July 21, 2012

These cars seem especially problematic. There is a rubber vacuüm block at the top of the throttle valve assembly. You will have to find a replacement at a junk yard (good luck). There are a lot of work-a-rounds for the vacuüm block but none seem to work – apparently the rubber block leaks just the right amount. Remove the cover this thing plugs into and clean the area and any rubber or residual stuff. Use some of the gooey black high temp gasket in a tube but don’t foul any of the holes. While you are at the junk yard find a set of the plastic lines that go with the rubber block – preferably all together in good condition. you can replace short bits of it with gel vac tubes -NOT RUBBER LINES (they leak too much) but in general you can’t replace all of it with anything but the hard formed GM lines. check each line segment with a vac pump kit to make sure they are not cracked and the seals do not leak. Also check the vac canister in front of the driver side front wheel. If this does not solve the problem, check the TPS and the MAP sensor to make sure their voltages is within tolerances – need needle probe to do this: check hot side, ground side, and signal on both – google for specs. Remove the PCM and clean the terminals and plugs. there are some expensive sprays at radar shack for doing this. WD40 is not a cleaner but might help with prevention later. Also check the codes, jumper method if nothing else. Sometimes these give an indication of the real problem, at least which part of the wiring has issues. Parts are expensive so test in place before replacing much of anything except the rubber block and vac lines. If you plan to keep the car, get to the junk yard and find a couple of these assemblies in decent shape, or plan to junk the car. They are no longer available, no replacement seems to work, and the TPS / MAP sensor combo are incredibly sensitive in this vehicle.